27 Dec 2008

My firefox addons

this is just a memo for myself :)
... but hope can be usefull to anyone

How to watch BBC iPlayer shows outside the UK

i've found this very interesting post !!

the only variations i've applied on my own are:

1) installed PortableTor (instead of the standard version)

2) edited manually the file ./Data/Tor.cfg
adding the following lines:

StrictExitNodes 1
exitnodes anotherlink,CarlosNet,ciccio,connorPC,PD,MrNiceGuy,procurator,shortname,colinwillsdorkyahoo,Hilikme,

Thx to Cherie!




You wanth to donload BBC iPlayer videos too?
checkout this post.
UPTADES: this no longer works anymore :(

6 Dec 2008

White screen with Compiz?

Compiz = white screen?

(1) TEMPORARY WORKAROUND

A quick way to temporary solve the white screen problem, is to remove compiz.

--> To quickly get out of the white screen, don't spend time rebooting in safe mode and stuff ...

Just follow those simple steps:

--> once you have your white screen desktop loaded ...

1) move to another desktop:
by pressing: CTRL + ALT + F1
2) login
3) remove compiz:
$ sudo apt-get remove compiz
$ sudo apt-get autoremove
4) return back to your desktop
CTRL + ALT + F7
5) restart the X session:
CTRL + ALT + BACKSPACE



(2) POSSIBLE SOLUTION

Running ATI? try this command:
$ aticonfig --initial -f

(3) POSSIBLE SOLUTION
Most of all is just a matter of configuration.
If you have a normal video card with 3D acceleration (even ATI :)) Compiz MUST work!

1) first of all update your system
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get dist-upgrade
(or $ yum update ... :)
2) you need to have your video driver correclty installed (look here for ATI)
3) check that X server can run correctly ($startx) (troubleshooting here)
4) start compiz (possible problems here)
5) in case you messed up with your xorg.conf, try deleting it. If startx runs, then follow the steps here, to create a new clean xorg.file. Finally start adding the needed parameters to make 3D acceleration and stuff.

18 Nov 2008

Common problems running compiz

I will run through the most common problems running COMPIZ with ATI drivers:
  • Try runnign compiz as ROOT
    this may seems stupid, but solved a lot of issues
    $ killall compiz
    $ sudo compiz
    At lest, if it works, you'll know what direction you have to look.

  • “desktop effects could not be enabled”
    if the desktop effects gui will raise this message, try running “compiz” inside a terminal, and see that it tells you.
  • “Checking for Xgl: not present.”
    this message is not a real problem as it may seems, compiz tries other configs, so don't loose time trying to fix it. Go ahead on this guide instead
  • “Another window manager is already running”
    this means exactly what it tells.
    Check inside “System preferences” → “Preferences” → “Sessions” if you have another wm running, for example: XCompMgr.
    In that case, kill it and try compiz again;
    $ killall xcompmgr
    $ sudo compiz
  • compiz white screen
    After reboot, when you login in GDM, your desktop is just a white screen?
    Follow this other POST to get back to a normal desktop.
  • compiz with no window decoration
    Your compiz has no window decoration? no window borders?
    This is mostly caused by compiz don't finding the needed files ...
    Open a termina and:
    $ killall compiz
    $ sudo compiz
    If this solved, you may need to check the System → preferences → Sessions and see what's wrong with the startup script.

  • compiz with no window decoration [2]
    Another possible cause may be the Video Drivers you'r using. Check for the latest version !!! or look for another driver to use with a newer but similar video card to the one you have.

Adding the compiz settings manager

it may be helpful to get the additional settings window available (in case you don't have it):

$ sudo aptitude install compizconfig-settings-manager

- or -

$ yum install ccsm

now, to run the compiz settings manager, go to
“System preferences” → “Preferences” → “Advanced Desktop Effects Settings”

or simply run:
$ ccsm

ATI DRIVER on DEBIAN / UBUNTU / GOS ...

Forget all the old complex installation methods with restricted drivers & xorg.conf modifications ...
Make it simpler!

what you need to make it work is:
  1. First of all: always make a copy of you old xorg.conf file:
    $ sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf .myoldconf
  2. install xserver-xgl:
    $ sudo apt-get install xserver-xgl
    You don't have to do anything else to set it up but restarting X (press: Ctrl + Alt + Bksp)
  3. download ati driver from http://ati.amd.com
    for Radeon cards: http://ati.amd.com/support/drivers/linux/linux-radeon.html
  4. install it (selecting all the default options)
    $ sudo sh ati-driver-installer-8-10-x86.x86_64.run
    In case of errors: don't worry, you may just need the kernel headers & gcc compiler. Checkout the log file shown upon compilation failure to see what you need.
    In my case it was:
    • $ sudo apt-get install linux-headers-2.6.24-26-generic (!! check the your kernel version!! by typing $uname-a );
    • $ sudo apt-get install gcc
  5. configure it
    $ sudo aticonfig –initial
  6. restart X server (by pressing CTRL + ALT + BKSP)

In short: follow those steps:

sudo apt-get install xserver-xgl
wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8-11-x86.x86_64.run
sudo sh ati-driver-installer-8-10-x86.x86_64.run
sudo aticonfig –initial


Commands to check if it is well installed:


me@gos:~$ glxinfo | grep direct
direct rendering: Yes

me@gos:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1300/X1550 Series
OpenGL version string: 2.1.8087 Release



Troubleshooting: startx X don't start

in case X server don't start, check the messages in the console after the $startx command.
It will explain you the reason.
In many cases, instead of loosing time, it may be a LOT EASYER to just remove the xorg.conf file.
$ rm /etc/X11/xorg.conf
and let startx use a default config:
$ startx
at this point, take a look inside the file /var/log/Xorg.0.log
you will find some lines similar to those of the xorg.conf syntax.
Finally: copy those lines in a new xorg.cong file and run startx. It should work.


Troubleshooting: Unable to find any supported Screen sections

Your /etc/X11/xorg.conf file has something wrong with the line:

Section “Screen”

or

Section "ServerLayout"
Screen [...]


File example for xorg.conf with ATI drivers:

Section "ServerLayout"
Identifier "Builtin Default Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
Load "extmod"
Load "dbe"
Load "glx"
Load "freetype"
Load "record"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
# !!! set your keyborad layout here !!!
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Builtin Default Monitor"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Builtin Default ati Device 0"
Driver "ati"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Builtin Default ati Screen 0"
Device "Builtin Default ati Device 0"
Monitor "Builtin Default Monitor"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection



Troubleshooting: Unable to find fglrx

If receiving many error messages with STARTX or compiling the ATI DRIVERS ...
even in the case you already installed the fglrx,

then it may be necessary to cleanup you system a little bit:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoclean
sudo apt-get clean

then try running again the 1st script (reinstall the ATI drivers, run ATICONFIG ... and so on)

15 Oct 2008

Search engines: your privacy is under attack

Your privacy is under attack !

Every time you use a regular search engine, your search data are recorded.
Your search terms, the time of your visit, the links you choose, your IP address and your User ID cookies all get stored in a database.

The identity profiles that can be constructed from this cloud of information represent modern day gold for marketers.
But government officials, hackers and even criminals al
so have an interest in getting their hands on your personal search data.
And sooner or later they will...


Ixquick is the only search engine that deletes your personal data.

When you search Ixquick you'r searching many popular engines
-anonymously- ... (read more)



Give it a try -->


10 Aug 2008

The Windows Installer Service could not be accessed

got one of those error messages?
"The Windows Installer Service could not be accessed"
"Error - 1608: Unable to create InstallDriver instance"

many pages out there explain how to solve this problems by running too deep into DLLs and Registry keys ... people sometimes forget some basics steps that most of the cases solves those problems:

1) check the windows service "Windows installer" is running

also note that InstallShield requires the DCOM service to be running too.
otherwise it will give this other error message:
"Error - 1608: Unable to create InstallDriver instance"
so, as a 2nd step:

2) check the windows service DCOM is running

or run this cmds:

NET START MSISERVER
NET START DCOMLAUNCH


goodluck

best free windows antiviru

Which is the best Free Windows Antivirus?

those are the AVs i did test:
AVG:
is probably the best, well updated.
It also has a nice internet protection which analyzes any link in every page you surf ... even on google pages. it display a green mark when the link if fine ... but pretty annoyng for me.
The worst this, running on my old laptop, was considerably downgrading the perf, so i had to remove it.

UP
- Frequetly updated
- Internet surfing security
DOWN
- Quite heavy for older machines


AVIRA:
Pretty nice.

UP
- Frequently updated.
DOWN
- Quite heavy for older machines


CLAMWIN:
it's open source, released under GPL, thus preferred for not comerrcial uses.
It doesn't has automatic scanning, this makes this product a bit more
for experienced users those who knows, beside an AV, when a file could be a problem.
On the other hand, this passive scanning has a
very low inpact!

UP
- Very low impact on system
DOWN
- Doesn't have an automatic scan (you have to manually scan)

MY CONCLUSIONS:
On my desktop i use AVG.
On my slower laptop i use CLAMWIN.

1 Aug 2008

Play MotoGP online


Lookin for a nice online MotoGP racing game?
Try this Ducati's sponsored game and your main problem will be keeping the front wheel down ... (shockwave player required)

link --> here


22 Jul 2008

VMware Server vs VirtualBox vs QEMU

all FREE, all GOOD


Since i used both in many OS, running many OS, the main difference between VirtualBox & VMware is the fact that:

>> if running from a linux box, when you update the kernel, VMW requires a recompilation. VB does not.

so this will affect you only if your main os is linux based, and you plan to update the kernel.
but even this situation is not a big deal, you just have to run a script and wait few minutes.

on the other side, both those software are FREE and works GOOD.
In my experience even on the PERFORMANCE side they're equivalent.
Obviously there are differences, but they vary for each guest os with each configuration.

You can even switch between both system just converting the img file.

30 Jun 2008

image editor online

at http://www.splashup.com/ you have an image editor online (flash made)


puzzlefarter online game

no comment :)

http://puzzlefarter.com/



VPN router-to-router using cisco 17xx / 18xx

[CBE - cisco by examples]

How to setup a VPN router-to-router using cisco 17xx / 18xx

Want to connect your cisco router to a CiscoVPN server?

the following lines will config your router to act as a VPNClient
and will tunnel the traffic on that VPN

check the ***STARRED*** values and replace it



crypto ipsec client ezvpn MyVpn
connect auto
group ***VPN_GORUP*** key ***VPN_GORUP_KEY***
mode client
peer ***VPN_SERVER_IP_ADDRESS***
username ***VPN_USER_NAME*** password ***VPN_USER_PASSWORD***
xauth userid mode local

interface Ethernet0
crypto ipsec client ezvpn MyVpn

interface FastEthernet0
crypto ipsec client ezvpn MyVpn inside


REMEBER: you may want to tunnelize only some traffic on the VPN CLIENT SIDE, and let all the other traffic transit outside the vpn. Then you have to config a SPLIT-TUNNEL on the VPN SERVER SIDE: check this post.



.

Enable a Cisco VPN Split Tunnel

[CBE - cisco by examples]

Need to a enable a VPN Split Tunnel on a cisco 17xx/18xx ?
Need to separate Subnets traffic from VPN tunneling?

1) define an ACL with the address to tunnel in VPN
2) add this ACL to a group

The client will automatically reconfigure itself at next connection.
No intervention needed on client config!


crypto isakmp client configuration group ***MY_GROUP***
key ***MY_GROUP_KEY***
pool SDM_POOL_1
save-password
include-local-lan
acl 150
!
access-list 150 permit ip any 192.168.10.0 0.0.0.255

How to create a cisco vpn server

[CBE - cisco by examples]

Here is an example showing the quickest way to enable a
VPN SERVER
on router Cisco 17xx / 18xx / ...

just check the ***STARRED*** values & replace it with yours;
this script uses a
LAN on 192.168.10.x and
VPN client on 192.168.11.x


!
aaa new-model
!
aaa authentication login default local
aaa authentication login sdm_vpn_xauth_ml_1 local
aaa authorization exec default local
aaa authorization network sdm_vpn_group_ml_1 local
!
aaa session-id common
!
resource policy
!
username ***USER1*** privilege 0 password 0 ***PASSWORD***
username ***USER2*** privilege 0 password 0 ***PASSWORD***
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp xauth timeout 15
!
crypto isakmp client configuration group ***MY_GROUP***
key ***MY_GROUP_KEY***
pool SDM_POOL_1
save-password
include-local-lan
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto dynamic-map SDM_DYNMAP_1 1
set transform-set ESP-3DES-SHA
reverse-route
!
crypto map SDM_CMAP_1 client authentication list sdm_vpn_xauth_ml_1
crypto map SDM_CMAP_1 isakmp authorization list sdm_vpn_group_ml_1
crypto map SDM_CMAP_1 client configuration address respond
crypto map SDM_CMAP_1 65535 ipsec-isakmp dynamic SDM_DYNMAP_1
!
interface Ethernet0
crypto map SDM_CMAP_1
!
ip local pool SDM_POOL_1 192.168.11.1 192.168.11.100
ip classes
!
ip nat inside source route-map SDM_RMAP_1 interface FastEthernet0 overload
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
route-map SDM_RMAP_1 permit 1
match ip address 100
!
end

play GOLF online ... you must give it a try

A flash GOLF game with photorealistic scenarios can be palyed at
http://worldgolftour.com/



Give it a try... you'll love it!!
PROBLEM WITH COLLATION on SQLSERVER?

try the following T-SQL codes to verify or alter the database,table or field collation:

check DATABASE collation:

select databasepropertyex(db_name(),'collation') as collation_name


alter DATABASE collation

alter database MYDB collate Latin1_General_CI_AS


check TABLE collation:

select column_name, collation_name
from INFORMATION_SCHEMA.COLUMNS
where table_name = 'MYTABLE'


check COLUMN collation:


select column_name, collation_name
from INFORMATION_SCHEMA.COLUMNS
where table_name = 'MYTABLE'



alter COLUMN collation:

alter table MYTABLE
alter column MYCOLUMN value varchar(20)
COLLATE Latin1_General_CI_AS


Following a script for checking and examinate all DB COLUMNS:
(NOTE: this script wont modify anything. It will just create code lines for you)


declare @toCollation sysname

set @toCollation = 'Latin1_General_CI_AS'
set @toCollation = select databasepropertyex(db_name(),'collation') as collation_name

print 'TO COLLATION --> ' + @toCollation

SELECT 'ALTER TABLE '+TABLE_NAME+' ALTER COLUMN '
+ COLUMN_NAME + ' ' + DATA_TYPE +
CASE WHEN CHARACTER_MAXIMUM_LENGTH = -1 then '(max)'
WHEN DATA_TYPE in ('text','ntext') then ''
WHEN CHARACTER_MAXIMUM_LENGTH IS NOT NULL
THEN '('+(CONVERT(VARCHAR,CHARACTER_MAXIMUM_LENGTH)+')' )
ELSE isnull(CONVERT(VARCHAR,CHARACTER_MAXIMUM_LENGTH),' ')
END +' COLLATE ' + @toCollation+ ' ' +
CASE IS_NULLABLE
WHEN 'YES' THEN 'NULL'
WHEN 'No' THEN 'NOT NULL'
END +' -- was '+COLLATION_NAME
FROM INFORMATION_SCHEMA.COLUMNS INNER JOIN INFORMATION_SCHEMA.TABLES
ON INFORMATION_SCHEMA.COLUMNS.TABLE_NAME = INFORMATION_SCHEMA.TABLES.TABLE_NAME
AND INFORMATION_SCHEMA.COLUMNS.TABLE_SCHEMA = INFORMATION_SCHEMA.TABLES.TABLE_SCHEMA
WHERE DATA_TYPE IN('varchar','char','nvarchar','nchar','text','ntext')
AND TABLE_TYPE = 'BASE TABLE' AND COLLATION_NAME<>@toCollation


NOTE 1
Altering a database collation doesn't alter his tables too...
only new tables/fields will be affected, so you'll need to check and alter your current structure manually.
Use the above script.

NOTE 2

if you have views, stored procs, or applications already working with the current collation, BE VERY CAREFULL on altering any column COLLATION.
Altering collations may cause errors like COLLATION CONFLICT !
eg:

Cannot resolve the collation conflict between "Latin1_General_CI_AS" and "Latin1_General_CS_AS" in the equal to operation.

if this happends, rollback your ALTERs.
This may be a message coming from a view or a stored...


Suggestion: never (i mean NEVER) alter a collation on a column if not necessary!!


13 Jan 2008

Addign Broadcast to GUARDDOG

After installing GUARDDOG,
if you have DHCP and are experiencing those messages
DROPPED IN=eth0 OUT= MAC=01:00:5e:00:00:01:00:c0:49:d3:6a:74:08:00 SRC=192.168.1.1 DST=224.0.0.1 LEN=28 TOS=0x00 PREC=0x00 TTL=1 ID=0 DF PROTO=2

that means the DHCP on
192.168.1.1 is sending you messages ...

to allow this traffic beetwen Client and DHCP Server,
just add a new zone, eg:
Name = DHCP
Address = 192.168.1.0/24
Connection = Internet




12 Jan 2008

IPTables GUI - Lokkit, Firestarter, Guarddog

Lokkit Vs Firestarter Vs Guarddog

Many linux distros installs a firewall by default. Mainly IPTABLES.

If you're looking for a Grafical Interface to easy configure your firewall rules in IPTABLES, then those are the main 3 choices:

1- Lokkit (terminal & gnome)
2- Firestarter
3- Guarddog (kde)

4- $ iptables
5- conclusions

--------

1- Lokkit (Terminal & GNOME)

The easiest one.
A wizard will guide you through few questions and will reconfigure IPTables for you.
Lokkit has a console and a gnome version:









The point is that, in case you need more control over the rules, this is not for you!

Here is an explanation guide

Note for Ubuntu users
: use Synaptic to install it, then go to
Menu -> applications -> Other -> Lokkit

--------

2- Firestarter

A nice one.
It provides a GUI for configuring rules and settings on IPTables.
Certainly more configurable than Lokkit, and allows to set up 95% of the rules for a normal use needs.

  • has a log window of "active connection" and "Real time Events" allowing to quickly check what's goin on;
  • add a very useful tryicon to open it in a click;
  • both inbound and outbound access policy;
  • Support for Denial of Service (DoS) attacks;
  • stealth ports;
  • whitelists and blacklists
  • ...
Here the main site.
Here the complete feauture list.

--------

3- Guarddog (KDE)

More professional...

If you are looking for something a bit more professional, then go for Guarddog (which is a KDE Gui).
Guarddog goes a bit deeper respect to Firestarter.
The 2 main differenced are
  1. Guardog doen't have a realtime event viewer (obviously you still can keep realtime infos "tailing" the logs in a terminal window);
  2. Guardog has more config options (Eg: NAT rules, connection tracking ...);








  • for KDE 2 or 3;
  • generates scripts for ipchains and/or iptables;
  • can create different zones with different policies;
  • Import/Export firewall scripts;
  • ipchain and iptables support;
  • ...
Here the homepage
Here the main feautures list
Here a well documented tutorial

--------

4- $ iptables

If you still prefer to do it by yourself, here you can find a nice HOWTO for strarting to learn the IPTABLES commands

--------

Conclusion

Lokkit

if you dont know or don't care too much about the firewall rules, and just want to add a firewall protection to you desktop.

Firestarter

if u want a full control of your firewall, and want to know in realtime what's going in/out and what's been blocked.

Guarddog

if you want a GUI that does almost the same as the $iptables command line, but don't wonna get crazy spending time to write 1 by 1 every single rule with $iptable on a console ... Guarddog will do it for you.

$ iptables

The old way. it controls everything.
But you still have to write everything by hands.


NNN